Bug Tracker

Modify

Ticket #5905 (closed bug: duplicate)

Opened 4 years ago

Last modified 3 years ago

slideDown and slideUp and min-height

Reported by: net4794 Owned by: brandon
Priority: critical Milestone: 1.4.1
Component: effects Version: 1.4
Keywords: slideUp slideDown Cc:
Blocking: Blocked by:

Description

When min-height is used in CSS, slideUp and slideDown do not function correctly. Instead of sliding, it will wait the time for it to slide and then just appear or disappear(according to which is used).

It took me about an hour of fidgeting with my jQuery and HTML until I noticed the inline CSS code may have to do with the problem.

$("#notice").delay(1500).slideUp();

<div id="notice" style="min-height:100px;"> asdf<br />asdf<br />asdf </div>

Everything else works, including the 'height' command. Please contact me as soon as this has been patched, thank you!

Change History

comment:1 Changed 3 years ago by dmethvin

  • Status changed from new to open
  • Summary changed from Problem with the slideDown and slideUp and an important, widely-used css command. to slideDown and slideUp and min-height

comment:2 Changed 3 years ago by dmethvin

  • Component changed from event to effects

comment:3 Changed 3 years ago by dtetto

I'd love to see this get fixed.

Duplicate of #6618, #4623, #4415 (includes a patch to fix) and #1004.

Even gets its own wiki entry:  http://docs.jquery.com/Tutorials:Getting_Around_The_Minimum_Height_Glitch

Going to disagree strongly with anyone who says it's not a bug; the various duplicates plus the need for a Wiki article to work around the "glitch" mean this one is tripping a lot of folks up.

The use case is: I want to toggle interface elements on and off with a slide or other animation, but the interface elements look bad if they're not at least 200px tall. So I give them a min-height; but, due to the bug, that prevents sliding from working correctly.

Here's a JSFiddle showing the bug still standing in 1.4.4:  http://jsfiddle.net/mLHb9/

I elaborate on my reasoning here (and receive some well-reasoned objections, though I happen to think they're wrong):  http://forum.jquery.com/topic/animations-should-temporarily-override-min-height-and-min-width

comment:4 Changed 3 years ago by snover

  • Status changed from open to closed
  • Resolution set to duplicate

comment:5 Changed 3 years ago by snover

Duplicate of #4623.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.