Bug Tracker

Ticket #4623 (closed enhancement: wontfix)

Opened 6 years ago

Last modified 4 years ago

css min-height / min-width breaks animation

Reported by: Abro Owned by:
Priority: minor Milestone: 1.4
Component: effects Version: 1.3.2
Keywords: css,min,height,width,animate,effect Cc:
Blocking: Blocked by:

Description

In my opinion the way our method css('min-height','...') works isn't as usable as it could be in the most cases out there. maybe i'm wrong. But let's say:

$(foo).css('min-height','100px');
$(foo).animate({height: '0px'},500);

The result is that there is no effect.

Maybe it's trivial and somewhere clear. But that's a thing where writing beautiful code isn't funny anymore. It's the same if i assign '10px' or '90px' to animate.

Well ... i know it's a question of how you look at it. But what happens if a plugin adds content to my website and i cannot handle its dimensions? I think that's Creepy.

Uh and : You're doing a great job!

Change History

comment:1 Changed 4 years ago by dmethvin

  • Component changed from unfiled to fx

comment:2 Changed 4 years ago by snover

  • Status changed from new to closed
  • Resolution set to wontfix

It’s up to the author to decide whether they want to have min-height overridden or if they want the animation to clamp to it. Since both options are valid, jQuery does nothing, and leaves it up to you to make the appropriate choice.

comment:3 Changed 4 years ago by snover

#5905 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.