Bug Tracker

Modify

Ticket #12474 (closed bug: fixed)

Opened 20 months ago

Last modified 19 months ago

Using find on a collection with append does not return the correct elements

Reported by: gbakernet Owned by:
Priority: blocker Milestone: 1.8.2
Component: traversing Version: 1.8.1
Keywords: Cc: timmywil, dmethvin
Blocking: Blocked by:

Description

Using find on a collection that has html appended was working in 1.8.0 and is not working in 1.8.1

Example  http://jsfiddle.net/p6389/

This code is based on current Cloud Zoom implementation.

Change History

comment:1 Changed 20 months ago by mikesherov

  • Cc timmywil, dmethvin added
  • Priority changed from undecided to blocker
  • Status changed from new to open
  • Component changed from unfiled to traversing
  • Milestone changed from None to 1.8.2

comment:2 Changed 20 months ago by rwaldron

That's an odd looking fiddle...

comment:3 Changed 20 months ago by d.galvez

This pull request fixes the issue:  https://github.com/jquery/sizzle/pull/152

comment:4 Changed 19 months ago by gibson042

I believe this to be a duplicate of #12337.

comment:5 Changed 19 months ago by dmethvin

  • Status changed from open to closed
  • Resolution set to duplicate

Duplicate of #12337.

comment:6 Changed 19 months ago by Timmy Willison

  • Resolution changed from duplicate to fixed

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.