Bug Tracker

Modify

Ticket #12285 (closed bug: fixed)

Opened 20 months ago

Last modified 20 months ago

Selector with :not(:first) isn't working since 1.8

Reported by: mail@… Owned by: timmywil
Priority: blocker Milestone: 1.8.1
Component: selector Version: 1.8.0
Keywords: Cc:
Blocking: Blocked by:

Description

I think, I've found a bug with the all new jQuery 1.8. When I have a selector, that contains :not(:first), then the complete selector doesn't have any effect. A common use case for such a selector is a simple accordion.

Testcase:  http://jsfiddle.net/X55tK/2/ (With jQuery 1.7.2 the testcase is working well)

Change History

comment:1 Changed 20 months ago by timmywil

  • Owner set to timmywil
  • Priority changed from undecided to blocker
  • Status changed from new to assigned
  • Component changed from unfiled to selector
  • Milestone changed from None to 1.8.1

Confirmed

comment:2 Changed 20 months ago by timmywil

#12287 is a duplicate of this ticket.

comment:3 Changed 20 months ago by timmywil

#12386 is a duplicate of this ticket.

comment:4 Changed 20 months ago by Timmy Willison

  • Status changed from assigned to closed
  • Resolution set to fixed

Update Sizzle: Use tokenization rather than regex for grouping. Fixes #12237, #12205, #12285.

Changeset: b2698928bbdc1b247cb6de28e9b2624ec6b56667

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.