Bug Tracker

Modify

Ticket #10622 (closed bug: fixed)

Opened 2 years ago

Last modified 2 years ago

.show() does not properly restore CSS-set "display" value

Reported by: warrenparsons Owned by: rwaldron
Priority: blocker Milestone: 1.7
Component: effects Version: 1.7rc1
Keywords: Cc:
Blocking: Blocked by:

Description

I've run into an issue in RC1 (and seemingly B2 as well) where using .show() does not restore an element's original, CSS-specified "display" value. Instead, it sets the element's "display" type to that element's browser-default value.

B1 does not have this issue for me.

I've set up a test case on jsfiddle at:  http://jsfiddle.net/6JbHh/

Change History

comment:1 Changed 2 years ago by rwaldron

  • Owner set to rwaldron
  • Priority changed from undecided to blocker
  • Status changed from new to assigned
  • Component changed from unfiled to effects
  • Milestone changed from None to 1.7

Confirmed: Regression.

Patch to follow.

Last edited 2 years ago by rwaldron (previous) (diff)

comment:2 Changed 2 years ago by rwaldron

I believe this was caused by the patch that timmywil and I wrote here:  https://github.com/jquery/jquery/commit/22f2e8b3dc18dede5f1ccb28cbdf8cb5bcde115f

comment:3 Changed 2 years ago by rwaldron

Further reduced, easier to understand:  http://jsfiddle.net/rwaldron/s7k4D/

comment:4 Changed 2 years ago by timmywil

  • Status changed from assigned to closed
  • Resolution set to fixed

Revert "Landing pull request 530. Fixes coniditional path for tr, td defaultDisplay() calls. Fixes #10416." Fixes #10622.

This reverts commit 22f2e8b3dc18dede5f1ccb28cbdf8cb5bcde115f.

Changeset: 0752687612d190f608e64181148ced1a4adfa5d6

comment:10 Changed 2 years ago by rwaldron

#10628 is a duplicate of this ticket.

Please follow the  bug reporting guidlines and use  jsFiddle when providing test cases and demonstrations instead of pasting the code in the ticket.

View

Add a comment

Modify Ticket

Action
as closed
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.