Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#9952 closed bug (duplicate)

attr ("disabled", true [or false or 1 or 0]) does not work properly in IE

Reported by: marllos Owned by: marllos
Priority: low Milestone: None
Component: attributes Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

The attr ("disabled",true) or attr ("disabled",false), works with jquery 1.5.1 and IE8, but not working in jquery 1.6.2 and IE8. In other browsers are ok.

Change History (5)

comment:1 Changed 8 years ago by timmywil

Component: unfiledattributes
Owner: set to marllos
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 8 years ago by jquery@…

http://jsfiddle.net/xWkdg/

It works in IE8 Standards mode, but not in Quirksmode.

Go figure! ;)

comment:3 Changed 8 years ago by jquery@…

p.s. The input actually gets disabled/enabled, but if you notice after it is re-enabled the text in the input is gray as if it was still disabled.

comment:4 Changed 8 years ago by timmywil

Resolution: duplicate
Status: pendingclosed

comment:5 Changed 8 years ago by timmywil

Duplicate of #9719.

Note: See TracTickets for help on using tickets.