Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9788 closed bug (duplicate)

.position() and .offset() return rotated values

Reported by: anonymous Owned by:
Priority: low Milestone: 1.next
Component: offset Version: 1.6.2
Keywords: Cc:
Blocked by: Blocking:

Description

This happens in Chrome, firefox works well. I don't test on other browsers.

If an element is rotated by '-webkit-transform: rotate(30deg)', the position() and offset() do not return the left/top value specified in css style. It gives the value transformed via the rotate matrix. There is a simple demo. http://jsfiddle.net/kevinxiao/92vfL/show

The two elements in demo are draggable. When the yellow one is dragged, it itself move towards top some pixels, I think that's caused by this bug.

My Chrome version is Chromium 11.0.696.71 (86024) Ubuntu 11.04

Change History (3)

comment:1 Changed 7 years ago by anonymous

comment:2 Changed 7 years ago by timmywil

Component: unfiledoffset
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:3 Changed 7 years ago by timmywil

Duplicate of #8362.

Note: See TracTickets for help on using tickets.