Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9576 closed bug (invalid)

removeAttr("disabled") on IE7

Reported by: vincent.benci@… Owned by: vincent.benci@…
Priority: low Milestone: 1.next
Component: attributes Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

BUG only on IE7 (FF and IE8 and IE9 is OK)

Sample :

$("#id_rectif_mail :input").removeAttr("disabled");

id_rectif_mail is a DIV

If i select each input then removeAttr("disabled") is OK .

Thanks in advance

Change History (7)

comment:1 Changed 8 years ago by anonymous

In fact, this is the TEXTAREA in the "ui dialog" that generate this bug , I think, and only on ie7 .

comment:2 Changed 8 years ago by timmywil

Component: unfiledattributes
Owner: set to vincent.benci@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:3 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:4 Changed 8 years ago by anonymous

Running IE8 in IE7 browser mode this error happens:

http://jsfiddle.net/yjsqc/

comment:5 in reply to:  4 Changed 8 years ago by anonymous

Replying to anonymous:

Running IE8 in IE7 browser mode this error happens:

http://jsfiddle.net/yjsqc/

On jQuery 1.6.2, that is. It works fine on 1.6.1

comment:6 Changed 8 years ago by timmywil

@anonymous: see #9719 As you can see, jQuery is doing everything it can. IE7 is not repainting: http://jsfiddle.net/timmywil/yjsqc/4/

comment:7 Changed 8 years ago by anonymous

I have also found that under certain hard-to-reproduce conditions .removeAttr('disabled') does not do the right thing in IE7. One very simple way around this is to use .prop('disabled', false) instead.

Note: See TracTickets for help on using tickets.