Bug Tracker

Opened 8 years ago

Closed 8 years ago

#9566 closed bug (invalid)

offset() return wrong top in Firefox 4.0.1 if using font-size:13px/1.231

Reported by: designbyjeeba@… Owned by: designbyjeeba@…
Priority: low Milestone: 1.next
Component: offset Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

Using offset to recover the left and top position of an element with a body with this size of font:

body {

font:13px/1.231 arial,helvetica,clean,sans-serif; /* for IE6/7 */ *font-size:small; /* for IE Quirks Mode */ *font:x-small;

}

give like +9 pixels of top position. Check this image for better understanding:

http://www.xhelos.com/jeeba/firefox4bug_complete.jpg

Im using Yahoo Reset.css version: 2.8.2r1, thats why the strange font size.

If i change from 13 to 11, then the top position with offset (and position() ) becomes ok. Im using Firefox 4.0.1 an other browsers (didnt test in IE) works ok.

Change History (7)

comment:1 Changed 8 years ago by jeeba

This ticket was created by me Jeeba, Didn't login

comment:2 Changed 8 years ago by Rick Waldron

Component: unfiledoffset

The problem I see with patching Firefox 4 bugs now is that Firefox is moving to an auto-update model similar to Chrome. In August of this year, the current version of Firefox will be 5 and 6 will be on the way.

comment:3 Changed 8 years ago by timmywil

Owner: set to designbyjeeba@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:4 Changed 8 years ago by Rick Waldron

#9580 is a duplicate of this ticket.

comment:5 in reply to:  3 Changed 8 years ago by jeeba

Replying to timmywil:

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced test case on http://jsfiddle.net that reproduces the issue experienced to help us assess your ticket.

Additionally, test against the jQuery (edge) version to ensure the issue still exists.

Ok, in 16 hours i will upload a test case =)

comment:6 Changed 8 years ago by jeeba

Ok, heres the demo: http://www.xhelos.com/game/colony.php?colony_id=260

Just open a Firebug console and execute this:

renderConstruction($('#Row12 #Column0'),xenoconstructions?[479])

Make sure to change the size of the body as the first image to note the difference.

comment:7 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.