Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9543 closed bug (duplicate)

prop and removeProp not properly worked in chrome 10.0.648.204

Reported by: Karsten <carsonng2000@…> Owned by:
Priority: low Milestone: 1.next
Component: attributes Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

I use a checkbox to trigger it simply like this:

if (jQuery('.checkbox').is(':checked')){
jQuery(".selectbox").removeProp('disabled');
}else{
jQuery(".selectbox").prop('disabled','disabled');
}

In firefox, it triggers perfectly. In chrome 10.0.648.204, it can trigger at the first time (enable then disable), but then it cannot trigger any more.

Change History (6)

comment:1 Changed 8 years ago by Karsten <carsonng2000@…>

comment:2 Changed 8 years ago by Rick Waldron

Component: unfiledattributes

Confirmed

comment:3 Changed 8 years ago by timmywil

Priority: undecidedlow
Resolution: invalid
Status: newclosed

Please do not remove native properties. Set them to false instead.

comment:4 Changed 8 years ago by timmywil

Resolution: invalid
Status: closedreopened

comment:5 Changed 8 years ago by timmywil

Resolution: duplicate
Status: reopenedclosed

comment:6 Changed 8 years ago by timmywil

Duplicate of #9140.

Note: See TracTickets for help on using tickets.