Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9470 closed bug (duplicate)

The unwrap() function unchecks checkboxes

Reported by: anonymous Owned by:
Priority: low Milestone: 1.next
Component: manipulation Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

I am using the unwrap function as a means of making certain content viewable. The wrapper is set to a visibility of hidden. Once removed, the content, which by default is visible, is revealed. All works perfectly in Firfox and Chrome. In IE 6, however, the checkboxes are becoming unchecked immediately after they are unwrapped. I used the following to verify that it was in fact unwrap():

alert($([checkbox]).attr('checked')); yields true $([checkbox]).unwrap(); alert($([checkbox]).attr('checked')); yields false

Not sure what's causing this. I can probably manage a workaround, but this shouldn't be happening. I've noticed problems with selections becoming unselected in the same manner, but haven't tested. Maybe this is fixed in later versions. Will have to check.

Change History (2)

comment:1 Changed 8 years ago by timmywil

Component: unfiledmanipulation
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:2 Changed 8 years ago by timmywil

Duplicate of #8500.

Note: See TracTickets for help on using tickets.