Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#9439 closed enhancement (duplicate)

Better definition for jq escaping script

Reported by: ottuzzi Owned by:
Priority: low Milestone: 1.next
Component: selector Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

on page[1] you can see the proposed jq script to escape period and colon characters as they are problematic as css selectors: I found that even $,{ and } need to be correctly escaped.

Here is the proposed change:

function jq(myId) {
   return '#' + myId.replace(/(:|\.|\{|\}|\$)/g,'\\$1');
}

Please let me know what you think about this change.

Thanks Bye Piero

[1]http://docs.jquery.com/Frequently_Asked_Questions#How_do_I_select_an_element_by_an_ID_that_has_characters_used_in_CSS_notation.3F

Change History (2)

comment:1 Changed 7 years ago by Rick Waldron

Component: unfiledselector
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:2 Changed 7 years ago by Rick Waldron

Duplicate of #5241.

Note: See TracTickets for help on using tickets.