Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#5241 closed bug (worksforme)

Periods and colons in jQuery id selectors

Reported by: maros Owned by: john
Priority: low Milestone:
Component: selector Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

Dots and colons in jQuery selectors don't seem to work, although they are allowed by the W3C specification.

does not work $('#element.1224') <span id="element.1224"></span>

works $('#element_1224') <span id="element_1224"></span>

Change History (4)

comment:1 Changed 6 years ago by dmethvin

  • Resolution set to worksforme
  • Status changed from new to closed

Special characters must be escaped with \\.

comment:2 Changed 5 years ago by jitter

  • Priority changed from major to low

comment:3 Changed 5 years ago by jitter

#8361 is a duplicate of this ticket.

comment:4 Changed 5 years ago by rwaldron

#9439 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.