Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9360 closed bug (duplicate)

Changed behavior of $.param()

Reported by: genuinebastard@… Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

In version 1.6.1 $.param() seems to omit empty arrays, so for example:

var obj = { a: 1, b: [] }; console.log($.param(obj));

prints out: a=1

In version 1.5.2 the result would be: a=1&b=

This causes problems with ajax requests etc.

Change History (3)

comment:1 Changed 9 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #6481, see the discussion there and in this forum thread: http://forum.jquery.com/topic/change-of-behavior-in-1-4-4-because-of-bug-6481

comment:2 Changed 9 years ago by dmethvin

Duplicate of #6481.

comment:3 Changed 9 years ago by timmywil

#9348 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.