Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9348 closed bug (duplicate)

Problem when sending empty arrays in the parameters of an ajax call

Reported by: [email protected] Owned by:
Priority: low Milestone: 1.next
Component: ajax Version: 1.6.1
Keywords: Cc:
Blocked by: Blocking:

Description

There is something strange when sending an empty array in a Ajax call, like

$.post(“/whatever”, {foo: [1,2,3], bar: []}, function(data) {…});

Using jQuery 1.5.2 the “bar” parameter gets in the server (Rails) as an empty array, but using 1.6.1 it does not appear in the request parameters at all.

Change History (2)

comment:1 Changed 10 years ago by timmywil

Component: unfiledajax
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

Closing as dupe of param ticket.

comment:2 Changed 10 years ago by timmywil

Duplicate of #9360.

Note: See TracTickets for help on using tickets.