Bug Tracker

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9032 closed bug (duplicate)

questionmark "??" problem when ajax operation

Reported by: xdommy Owned by:
Priority: low Milestone: 1.next
Component: ajax Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

This problem is not closed. In version 1.5.2 persist

If I try this code:

var JSonData = '{"value":"try ??"}';

$.ajax({

type: "POST", url: "WCF_Services.aspx/DoWork", data: JSonData, contentType: "application/json", dataType: "json", success: function (input) {

alert(input.d);

}

});

it produce this JSON OBJECT in request:

{"value":"try jQuery1520880517924837633_1304179966549"}

Change History (3)

comment:1 in reply to: ↑ description Changed 5 years ago by anonymous

I want to add that the same code works fine in jquery 1.4.4. In jquery 1.5, 1.5.1 and 1.5.2 don't work, produce this bug

Replying to xdommy:

This problem is not closed. In version 1.5.2 persist

If I try this code:

var JSonData = '{"value":"try ??"}';

$.ajax({

type: "POST", url: "WCF_Services.aspx/DoWork", data: JSonData, contentType: "application/json", dataType: "json", success: function (input) {

alert(input.d);

}

});

it produce this JSON OBJECT in request:

{"value":"try jQuery1520880517924837633_1304179966549"}

comment:2 Changed 5 years ago by rwaldron

  • Component changed from unfiled to ajax
  • Priority changed from undecided to low
  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 Changed 5 years ago by rwaldron

Duplicate of #8417.

Note: See TracTickets for help on using tickets.