Bug Tracker

Opened 9 years ago

Closed 9 years ago

#8918 closed bug (invalid)

$.each() doesn't work in IE 7 when there are dots in index names

Reported by: david@… Owned by: david@…
Priority: low Milestone: 1.next
Component: core Version: 1.5.2
Keywords: Cc:
Blocked by: Blocking:

Description

This causes: Microsoft JScript runtime error: 'length' is null or not an object in line 605 in jQuery 1.5.2 development.

The code causing the error is

$.each(nde.properties, function(index, value) { 
  if (index == "scs.sid") dbMap[value] = keys.slice();
});

I suspect that the problem is that the key contains a dot. This is something IE 7 has problems with.

Change History (2)

comment:1 Changed 9 years ago by timmywil

Component: unfiledcore
Owner: set to david@…
Priority: undecidedlow
Status: newpending

Thanks for taking the time to contribute to the jQuery project! This issue is most likely a regular javascript error, but if this is a jQuery issue, please provide a reduced test case on http://jsFiddle.net that reproduces the issue experienced to help us assess your ticket. Additionally, test against the jQuery (edge) version to ensure the issue still exists.

comment:2 Changed 9 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.