Skip to main content

Bug Tracker

Side navigation

#8917 closed bug (wontfix)

Opened April 19, 2011 12:54PM UTC

Closed April 20, 2011 02:03PM UTC

Last modified January 30, 2013 05:10PM UTC

jQuery not loading over 3g or Edge on 02 network .

Reported by: Owned by:
Priority: low Milestone:
Component: web Version: 1.5.2
Keywords: dbr Cc:
Blocked by: Blocking:


I work for Reapit Ltd a UK based company that is a market leader in Estate Agency software. I am currently tasked with creating a Web Application for the iPhone.

A few months back I came across an issue with JavaScript files not loading correctly and throwing seemingly random syntax errors. The issue was only happening when the iPhone was using a 3g or Edge connection. After some research into the issue I found that 02 (UK network provider) seems to be screwing around with JavaScript in an attempt to optimize load times. Check these articles out:

Its a very frustrating issue. I systematically eliminated all the js files I load and have found that the more recent versions of the jQuery library will not work regardless of being minified or not.

The last version that I know works for me is 1.4.4. I was just interested to see if anyone else has had this issue as it has had me pulling my hair out. I havent been able to test on other networks but have tested all versions of the iphone and I get the same issue.

I havent had time to try and work on a fix, as the article states, the syntax error can be different depending on the load times of the 02 proxy servers.



Attachments (0)
Change History (12)

Changed April 20, 2011 02:03PM UTC by addyosmani comment:1

priority: undecidedlow
resolution: → wontfix
status: newclosed

Thanks for submitting a ticket to the jQuery Bug Tracker. Please note the following from the SO thread you referenced:

''I've investigated this further and discovered that the problem is that the UK mobile operator O2 (the original exclusive iPhone operator for Apple), modifies web content before sending it to iPhones and iPads. Probably before sending it to any device running a mobile browser.''

Unfortunately, we are unable to modify jQuery to work around situations where third parties may apply filtering or otherwise modify the code/usage/inclusion of the code as a part of their distribution process. Where this is a concern, it's recommended that you contact O2/the mobile operator directly and attempt to have them resolve this. It may assist by providing a summary of why a fix is necessary (the content you submitted in your ticket would probably suffice).

Changed April 27, 2011 03:21PM UTC by anonymous comment:2

I have the same issue with my provider (T-Mobile) in Holland and an iPhone website. Seems to work in Wifi mode, doesn't load JQUERY in 3G mode. Temporarily fixed it by downgrading to 1.4.4 but that doesn't sound like a good option!

Changed April 27, 2011 08:41PM UTC by anonymous comment:3

Same here also with Vodafone NL

strange thing is, if you use

also, if you look at the source you'll see that the comments aren't stripped

Changed April 27, 2011 09:19PM UTC by rwaldron comment:4

component: unfiledweb

Yes, the comments are stripped, however the header is left in tact.

Changed May 16, 2011 03:54PM UTC by Holger comment:5

Well, at least for T-Mobile in Germany my colleagues and I have found a way around this:

As T-Mobile seems to omit JavaScript files that are in the same (sub-)folder on the webserver when loading a webpage you have two options:

Solution 1:

Put jQuery file in a different (higher level) folder, e.g. and


Solution 2:

Use the CDN hosted version of jQuery (as this is on a different server).

We've tested this with multiple devices and providers. Seems that only T-Mobile does that crap (thanks a lot) and both solutions worked in all cases on all devices (with all 4 German providers) we tested.

Changed May 31, 2011 09:08AM UTC by comment:6

I ran into the same issue with O2 in UK. If i view the source it of the page it merges all the javascript/css into the head of the html.. which I assumes is to speed up the loading. But this does stop jquery from working correctly. I by default always layer my scripts and css into different directories. So.. the post by Holger on solution one did not work by default in UK.. I will still try to add the CDN and see what happens.

This only happens if i use 3G tethered via Bluetooth. So i think the site thinks i am actually using some old Nokia to try and view the site and strips stuff out. If i use the proper HSDPA Huwaie Dongle it does not do this.

I think there needs to be something added to the head of the file to stop these services from compressing/stripping or modifying content. I am just not sure what it would be.

Changed July 14, 2011 07:06PM UTC by jorritdeklerk comment:7

Had this with T-Mobile NL. Everything was working fine on server A (with local jQuery files) until I put my WebApp on a server B. Server A was using SSL, server B was not.

So when it's SSL the provider cannot 'optimize' the files (logically, because the provider cannot look into the files) so everything keeps working.

So, SSL can be a 'workaround'.

For server B I now use the CDN hosted files and this works.

Changed December 15, 2011 03:08PM UTC by comment:8

We've had this error on iPhone 4:

"SyntaxError: Parse error"

and then changing the link to CDN one fixed it on our end.

Thanks for the tip!

Changed May 19, 2012 09:45AM UTC by anonymous comment:9

Just so anyone visiting this thread still hasn't found the answer to solving this. Here it is:

Just set your Response Header from your server to include: Cache-Control:no-transform

Here's kudos to how I discovered this:

and the stackoverflow question:

Changed June 14, 2012 02:17PM UTC by anonymous comment:10

We've had this issue on the iPad in the UK, thanks for these posts as switching to linking to the CDN hosted files fixed the problem.

Changed January 30, 2013 04:55PM UTC by anonymous comment:11

Comment-Bug in jquery.themepunsh.revolution.js prohibit js-compression using mobile connections!!!

line 1885!!!

Changed January 30, 2013 05:10PM UTC by mikesherov comment:12

keywords: → dbr