Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8577 closed bug (duplicate)

PROBLEM WITH FADEIN ON IE8 and PNG

Reported by: debug@… Owned by:
Priority: undecided Milestone: 1.next
Component: unfiled Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Description

The ticket #6412 (PROBLEM WITH FADEOUT ON IE8) was closed as invalid bug : "You can’t mix opacity and alpha-transparent images in IE unless you apply the opacity directly to an alpha-transparent <img> tag."

OK. But we use fadeOut or fadeTo to fade many divs and then fadeIn to get them normal. I think it would be better not to use alpha filter when using fadeIn or fadeTo(1). It would be more natural for the programmer if the sequence fadeOut then fadeIn would leave things unchanged. This is not the case since the PNGs get broken in the process.

I made a correction in jQuery.cssHooks.opacity, set function :

var opacity = ( jQuery.isNaN(value)
value == 1 ) ? "" : "alpha(opacity=" + value * 100 + ")";

instead of

var opacity = jQuery.isNaN(value) ? "" : "alpha(opacity=" + value * 100 + ")"

Thank you.

Change History (2)

comment:1 Changed 9 years ago by dmethvin

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by dmethvin

Duplicate of #8576.

Note: See TracTickets for help on using tickets.