Bug Tracker

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#8456 closed bug (fixed)

trigger('mouseover') no longer triggers mouseenter

Reported by: john.firebaugh Owned by: dmethvin
Priority: blocker Milestone: 1.5.2
Component: event Version: 1.5.1
Keywords: Cc:
Blocked by: Blocking:

Change History (6)

comment:1 Changed 5 years ago by dmethvin

  • Component changed from unfiled to event
  • Milestone changed from 1.next to 1.5.2
  • Priority changed from undecided to blocker
  • Status changed from new to open

comment:2 Changed 5 years ago by henrik.hjelte@…

Ah, someone saw this bug before me, I have another fiddle example that documents it and shows the fix: http://jsfiddle.net/zg6Na/18/

This works with jquery up to and including 1.5, starts breaking with 1.5.1 The problem is on line 2788 of dist/jquery.js (of 1.5.1)

Modified jquery.js


  • if ( parent !== document && !parent.parentNode ) {

+ if ( parent !== document && (parent && !parent.parentNode )) {

comment:3 Changed 5 years ago by dmethvin

  • Owner set to dmethvin
  • Status changed from open to assigned

comment:4 Changed 5 years ago by dmethvin

Fix: https://github.com/jquery/jquery/pull/266

BTW, john.firebaugh, thanks for the report and for finding the problem commit!

Last edited 5 years ago by dmethvin (previous) (diff)

comment:5 Changed 5 years ago by john

  • Resolution set to fixed
  • Status changed from assigned to closed


comment:6 Changed 5 years ago by dmethvin

#8624 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.