Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7938 closed bug (duplicate)

.val() returns innerHTML for button elements in IE7

Reported by: anonymous Owned by:
Priority: high Milestone: 1.6
Component: manipulation Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

See ticket #1954 for full details including a patch, but the short version is:

This was reported back in 2007 before IE8 was released. A patch for it was attached but never applied. That ticket was closed in 2010 as worksforme based on testing in IE8, but Microsoft had fixed the underlying browser bug in IE8 while IE7 is still affected.

The workaround in that patch (using elem.getAttributeNode('value').value) works well in all my tests, but no-one is able to re-open #1954 to get it applied.

Change History (2)

comment:1 Changed 9 years ago by jitter

Component: unfiledmanipulation
Milestone: 1.next1.6
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by jitter

Duplicate of #1954.

Note: See TracTickets for help on using tickets.