Bug Tracker

Opened 8 years ago

Closed 8 years ago

#7903 closed bug (invalid)

.attr() does not recognize "shape" in <area>

Reported by: Anonymous Owned by: Anonymous
Priority: undecided Milestone: 1.next
Component: event Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

In <area>-tags the shape-attribute is not recognised by .attr()

Deleting areas with no shapes doesn't work: focusable = focusable.map(function(){return($(this).attr('shape') === undefined && $(this).is('area')) ? null : this;});

Deleting areas with no href works: focusable = focusable.map(function(){return($(this).attr('href') === undefined && $(this).is('area')) ? null : this;});

Change History (7)

comment:1 Changed 8 years ago by ajpiano

Owner: set to Anonymous
Status: newpending

Thanks for your time and interest in helping with jQuery! In accordance with the bug reporting guidelines, please create a reduced test case on jsFiddle that demonstrates the issue.

comment:2 Changed 8 years ago by Anonymous

Status: pendingnew

BACKGROUND-INFORMATION ======================

  • Consider a plugin that emulates TAB-keyboard-navigation by the user, i.e. a plugin that is able to set the focus to the next element in the tab-order (given a certain block-element, a focusable inline-element)
  • "focusable" is a set of jQuery objects which was retrived by a .find() operation
  • According to http://dev.w3.org/html5/spec/editing.html#focus, especially "7.3.2 Focus management", <area>-tags which have no shape-attribute are regarded as 'not focusable'.

THE POTENTIAL BUG ================= Deleting areas with a missing shape attribute from the list of focusable jQuery object doesn't work: focusable = focusable.map(function(){return($(this).attr('shape') === undefined && $(this).is('area')) ? null : this;});

If you do (just for the sake of testing) the same with missing href-attributes, the code works perfectly (however I don't need hrefs, but shapes!!): focusable = focusable.map(function(){return($(this).attr('href') === undefined && $(this).is('area')) ? null : this;});

comment:3 Changed 8 years ago by addyosmani

#7907 is a duplicate of this ticket.

comment:4 in reply to:  3 Changed 8 years ago by anonymous

Replying to addyosmani:

#7907 is a duplicate of this ticket.

!!! ATTENTION !!! #7907 says that .focus() does not work with <area> (but should according to w3c). This ticket says that I can work with areas ( .attr() works in some way), but .attr() recognises only 'href' and not 'shape'. So it's not a REAL dublicate. However both bugs (without having looked at the jQuery code) maybe interrelated (maybe in so far that <area> and its attributes are poorly supported).

Therefore: When fixing this, please consider both use-cases.

comment:5 Changed 8 years ago by Rick Waldron

Status: newpending

Despite the information you've added...

Please provide a reduced jsFiddle test case, using the latest stable jQuery release and the jQuery 0 GIT version to ensure the issue still exists.

Part of creating a reduced test case helps us determine how to proceed with addressing the bug.

comment:6 Changed 8 years ago by Rick Waldron

Component: unfiledevent

comment:7 Changed 8 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.