Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7760 closed bug (duplicate)

animate left to values over -11000px

Reported by: sofa@… Owned by:
Priority: low Milestone: 1.5
Component: effects Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

when i use animate like $('#content').animate({left:-1000}); and the value of left is already beneath -10000 it hops to -1000.

Change History (6)

comment:1 Changed 9 years ago by sofa@…

I just tested it and it was introduced with jquery. 1.4.3 it worked up to this version.

comment:2 Changed 9 years ago by sofa@…

an example is here: http://jsfiddle.net/GBLqa/

comment:3 Changed 9 years ago by stenehall@…

Here's the reason:

Animate uses e.cur() to get it's start value. That will return 0 if a value smaller than -10000 is used.

Line 6623 of jquery 1.4.4: return r && r > -10000 ? r : 0;

My current solution is to just change that value to something smaller than I know I will be using.

comment:4 Changed 9 years ago by jitter

Resolution: duplicate
Status: newclosed

comment:5 Changed 9 years ago by jitter

Duplicate of #7193.

comment:6 Changed 9 years ago by jitter

Component: unfiledeffects
Milestone: 1.61.5
Priority: undecidedlow
Note: See TracTickets for help on using tickets.