Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7741 closed bug (duplicate)

Selecting element with attribute containing [ or ] does not work since 1.4.4

Reported by: tim@… Owned by:
Priority: undecided Milestone: 1.6
Component: unfiled Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

I have an input named data[User][openid] and want to select it using jQuery. The following code worked using jQuery 1.4.3 but does not work anymore using 1.4.4 (served from http://ajax.googleapis.com/ajax/libs/jquery/1.4.4/jquery.min.js)

<input name="data[User][openid]" />
<script>
// This should alert 1, but alert 0 in 1.4.4
alert($('input[name=data\\[User\\]\\[openid\\]]').length);
</script>

Change History (5)

comment:1 Changed 9 years ago by jitter

Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by jitter

Duplicate of #7596.

comment:3 Changed 9 years ago by jitter

Resolution: duplicate
Status: closedreopened

sorry had the wrong ticket on my mind

comment:4 Changed 9 years ago by jitter

Resolution: duplicate
Status: reopenedclosed

Actually duplicate of this one

comment:5 Changed 9 years ago by jitter

Duplicate of #7539.

Note: See TracTickets for help on using tickets.