Bug Tracker

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#7539 closed bug (duplicate)

Attribute selector equals with escaped value fails in IE8

Reported by: dennis@… Owned by: john
Priority: blocker Milestone: 1.5
Component: selector Version: 1.4.4
Keywords: Cc: Rick Waldron
Blocked by: Blocking:

Description

Having:

<input name="foo[bar]" type="text" />

the following:

alert($("[name=foo\\[bar\\]]").length);

alerts 0 in IE8 together with jQuery v1.4.4, while it alerted 1 correctly with v1.4.3.

This causes serious problems when operating on form elements with array-styled names.

Change History (16)

comment:1 Changed 11 years ago by Rick Waldron

Resolution: invalid
Status: newclosed

Escaped or not, attributes MUST be quoted

http://jsfiddle.net/rwaldron/mrtCs/

comment:2 Changed 11 years ago by jitter

Resolution: invalid
Status: closedreopened

comment:3 Changed 11 years ago by jitter

Component: unfiledselector
Priority: undecidedblocker
Status: reopenedopen

test case

As per discussion with csnover. The escaped but unquoted selector needs to work as it's valid CSS3 selector syntax and also is correctly handled by qSA. There is no good reason for this selector suddenly failing since jQuery 1.4.4,

Last edited 11 years ago by jitter (previous) (diff)

comment:4 Changed 11 years ago by jitter

Milestone: 1.51.4.5

comment:5 Changed 11 years ago by Rick Waldron

Cc: Rick Waldron added

comment:6 Changed 11 years ago by jitter

#7596 is a duplicate of this ticket. <-- wrong

Last edited 11 years ago by jitter (previous) (diff)

comment:7 Changed 11 years ago by jitter

#7691 is a duplicate of this ticket.

comment:8 Changed 11 years ago by jitter

#7741 is a duplicate of this ticket.

comment:9 Changed 11 years ago by jitter

#7777 is a duplicate of this ticket.

comment:10 Changed 11 years ago by jitter

#7813 is a duplicate of this ticket.

comment:11 Changed 11 years ago by ajpiano

Milestone: 1.4.51.5

comment:12 Changed 11 years ago by ajpiano

Milestone: 1.51.4.5

comment:13 Changed 11 years ago by john

Owner: set to john
Status: openassigned

comment:14 Changed 11 years ago by dmethvin

Milestone: 1.4.51.5

comment:15 Changed 11 years ago by john

Resolution: duplicate
Status: assignedclosed

comment:16 Changed 11 years ago by john

Duplicate of #6093.

Note: See TracTickets for help on using tickets.