Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#7665 closed bug (worksforme)

$.fn.data broken in jQuery 1.4.4 (related to pulling HTML5 data- attributes)

Reported by: cobexer Owned by: cobexer
Priority: high Milestone: 1.5
Component: data Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

in jQuery 1.4.4 calling $(window).data() results in an error same for document(and everything that has no attributes property)

Change History (13)

comment:1 Changed 7 years ago by Rick Waldron

Owner: set to cobexer
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a reduced jsFiddle test case to help us assess your ticket!

Additionally, test against the latest jQuery release AND the jQuery 0 GIT version to ensure the issue still exists. Be Excellent to eachother!

comment:2 Changed 7 years ago by jitter

Duplicate of #7500?

comment:3 Changed 7 years ago by Rick Waldron

Resolution: duplicate
Status: pendingclosed

It sure is. Thanks Jitter

http://jsfiddle.net/rwaldron/tGHc5/3/

comment:4 Changed 7 years ago by Rick Waldron

Duplicate of #7500.

comment:5 Changed 7 years ago by cobexer

I now added https://github.com/jquery/jquery/pull/115 to fix this, then realized it was closed as duplicate however the other tickets (and the linked commits) do not seem to cover this.

please have a look at the changes i made

comment:6 Changed 7 years ago by jitter

Resolution: duplicate
Status: closedreopened

comment:7 Changed 7 years ago by jitter

Component: unfileddata
Milestone: 1.next1.4.5
Priority: undecidedhigh
Status: reopenedopen

comment:8 Changed 7 years ago by jitter

Status: openassigned

comment:9 Changed 7 years ago by Rick Waldron

Nice catch

comment:10 Changed 7 years ago by john

Status: assignedpending

The approach taken in #7500 is certainly different but it covers the case handled here (and in a much better way). Can you please re-test now that the code is landed? Thanks!

comment:11 Changed 7 years ago by Rick Waldron

Resolution: worksforme
Status: pendingclosed

I just ran the test against all the supported browsers using jQuery 0 GIT and it no longer throws an exception.

comment:12 Changed 7 years ago by john

Version: 1.4.41.5

There wasn't a 1.4.5 release, was actually 1.5.

comment:13 Changed 7 years ago by john

Milestone: 1.4.51.5

There was no 1.4.5 release, was actually 1.5.

Note: See TracTickets for help on using tickets.