Bug Tracker

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#7643 closed bug (duplicate)

Sizzle querySelectorAll doesn't work when element id contains special characters

Reported by: schneidh@… Owned by:
Priority: high Milestone: 1.5
Component: selector Version: 1.5
Keywords: Cc:
Blocked by: Blocking:

Description

I noticed an issue where the querySelectorAll call fails in Sizzle when the search element id contains a special character like a period. This was not an issue in jquery 1.4.3 as the id __sizzle__ was always used in that version. I implemented a simple fix where periods are escaped and that resolved my issue nicely. (Obviously all special characters will need to be escaped)

This issue is a regression caused by the fix for: http://bugs.jquery.com/ticket/7212

Change History (6)

comment:1 Changed 8 years ago by anonymous

Here's a simple test case for this bug that worked with jquery 1.4.3/1.4.2, but does not with jquery 1.4.4: http://jsfiddle.net/73mBB/5/

comment:2 Changed 8 years ago by anonymous

My apologies, this is a duplicate of bug: http://bugs.jquery.com/ticket/7533

comment:3 Changed 8 years ago by jitter

Component: unfiledselector
Milestone: 1.next1.4.5
Priority: undecidedhigh
Resolution: duplicate
Status: newclosed

comment:4 Changed 8 years ago by jitter

Duplicate of #7533.

comment:5 Changed 8 years ago by john

Version: 1.4.41.5

There wasn't a 1.4.5 release, was actually 1.5.

comment:6 Changed 8 years ago by john

Milestone: 1.4.51.5

There was no 1.4.5 release, was actually 1.5.

Note: See TracTickets for help on using tickets.