Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#7638 closed bug (duplicate)

Incorrect animate behaviour in WebKit

Reported by: tbicr.by@… Owned by: tbicr.by@…
Priority: low Milestone: 1.5
Component: effects Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Hi!

I use jQuery animation as following:

selector.animate({top: '-=' + pageHeight}, time, callback); selector.animate({ 'margin-left': '-=' + windowWidth }, time, callback);

In InternetExplorer, FireFox everything is all right. In Google Chrome when zoom equals 100% all right too, but when set other zoom (not equal 100%), animation occurs in spurts and in result 'top' and 'margin-left' values set incorrect (proportional zoom-level).

Chrome version 7.0.517.44

Change History (13)

comment:1 Changed 9 years ago by tbicr.by@…

Hi!

I use jQuery animation as following:

selector.animate({top: '-=' + pageHeight}, time, callback); selector.animate({ 'margin-left': '-=' + windowWidth }, time, callback);

In InternetExplorer, FireFox everything is all right. In Google Chrome when zoom equals 100% all right too, but when set other zoom (not equal 100%), animation occurs in spurts and in result 'top' and 'margin-left' values set incorrect (proportional zoom-level).

Chrome version 7.0.517.44

comment:2 Changed 9 years ago by jitter

Owner: set to tbicr.by@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report!

Please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further.

comment:3 Changed 9 years ago by tbicr.by@…

Status: pendingnew

See example:

http://jsfiddle.net/HRuKA/

Try to zoom in and click some times up/down buttons in Chrome browser And compare results using Firefox or Chrome when zoom is 100%

comment:4 Changed 9 years ago by tbicr.by@…

Most likely it depends on incorrect work function $(selector).css(name) in chrome when zoom isn't 100%

comment:5 Changed 9 years ago by jitter

Component: unfiledeffects
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:6 Changed 9 years ago by jitter

#7638 is a duplicate of this ticket.

comment:7 Changed 9 years ago by jitter

Duplicate of #7638.

comment:8 Changed 9 years ago by jitter

Resolution: duplicate
Status: closedreopened

comment:9 Changed 9 years ago by jitter

Resolution: duplicate
Status: reopenedclosed

comment:10 Changed 9 years ago by jitter

Duplicate of #5565.

comment:11 Changed 6 years ago by maciekpaprocki@…

ok I have this same problem in webkit browsers (safari and chrome). Everything works fine until I zoom site.

this same example, because it shows everything. http://jsfiddle.net/HRuKA/

works fine in IE and MF.

comment:12 Changed 6 years ago by anonymous

I can confirm I have seen this behavior as well.

comment:13 Changed 6 years ago by kulshreshtha.somil007@…

yes same happen to me also

Note: See TracTickets for help on using tickets.