Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#7582 closed bug (duplicate)

a.setAttribute is not a function

Reported by: anonymous Owned by: anonymous
Priority: low Milestone: 1.5
Component: attributes Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Erreur : a.setAttribute is not a function Fichier Source : jquery-1.4.4.min.js Ligne : 55

works fine with 1.4.3

Change History (6)

comment:1 Changed 7 years ago by jitter

Owner: set to anonymous
Status: newpending

Thanks for taking the time to contribute to the jQuery project by writing a bug report!

Please submit a reduced test case, which reproduces the issue you are experiencing, on http://jsfiddle.net. So that we can investigate this issue further.


How to report bugs

comment:2 Changed 7 years ago by Rick Waldron

Component: unfiledattributes
Priority: undecidedlow

I'm going to bet that this is a duplicate of #7500

comment:3 Changed 7 years ago by sasfater@…

comment:4 Changed 7 years ago by addyosmani

Resolution: duplicate
Status: pendingclosed

Closing as a duplicate of #7500 and #7607, both of which were related to the known attributes bug.

comment:5 Changed 7 years ago by addyosmani

Duplicate of #7607.

comment:6 Changed 7 years ago by anonymous

This could fix it...

 // Ensure that missing attributes return undefined
        // Blackberry 4.7 returns "" from getAttribute #6938
        if (elem.attributes == null ||!elem.attributes[ name ] && (elem.hasAttribute && !elem.hasAttribute( name )) ) {
            return undefined;
        }
Note: See TracTickets for help on using tickets.