Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#7517 closed bug (duplicate)

Uncaughted exception when call attr('tagName')

Reported by: quaff Owned by:
Priority: low Milestone: 1.5
Component: attributes Version: 1.4.4
Keywords: tagName exception attr Cc:
Blocked by: Blocking:

Description

$(document).attr('taggName'); will throw exception: TypeError: Cannot read property 'tagName' of null

'undefined' returns in jquery-1.4.3,query-1.4.2 ....

it's not backward compatible

Change History (5)

comment:1 Changed 7 years ago by jeremy@…

Confirm this in FF3.5 jquery 1.4.4

comment:2 Changed 7 years ago by jitter

Duplicate of #7500

comment:3 Changed 7 years ago by addyosmani

Component: unfiledattributes
Keywords: tagName exception attr added
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

comment:4 Changed 7 years ago by addyosmani

Duplicate of #7500.

comment:5 Changed 6 years ago by anonymous

The spaces on the type name are causing this problem.

Note: See TracTickets for help on using tickets.