Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#7222 closed bug (fixed)

data() doesn't retrieve HTML 5 data-* attribtues

Reported by: jitter Owned by:
Priority: undecided Milestone: 1.4.4
Component: unfiled Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

When calling data() (with no parameter) the returned object doesn't include the since 1.4.3 supported HTML 5 data-* attributes

test case

Change History (2)

comment:1 Changed 6 years ago by John Resig

  • Resolution set to fixed
  • Status changed from new to closed

Make sure that .data() (no args) returns a list of all the data- properties as well. Also make sure that accessing a data- property via .data() doesn't cause it to change again at a later time (it should be static). Fixes #7222, #7223.

Changeset: 8a5df39045292397a06d08b4fab2ad29819b5d44

comment:2 Changed 6 years ago by john

#7332 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.