Bug Tracker

Opened 9 years ago

Closed 8 years ago

Last modified 7 years ago

#7160 closed bug (duplicate)

only set overflow in $.fn.animate when the default overflow is visible

Reported by: hugodevreugd Owned by:
Priority: low Milestone: 1.next
Component: effects Version: 1.4.3
Keywords: Cc:
Blocked by: Blocking:

Description

When you have a hidden div in IE8 with CSS overflow:auto, and a height set in CSS less than the height of the div (so it will get scroll bars when displayed). Then when you use $("#thediv").show(); jQuery 1.4.3.rc1 displays the div correctly with scroll bars, but when you use $("#thediv").show("slow"); jQuery 1.4.3.rc1 displays the div incorrectly without any scroll bars. In 1.4.2 scroll bars are displayed correctly in both cases. Other browser like FireFox or Chrome did display the scroll bars in jQuery 1.4.3.rc1 in both cases.

Change History (4)

comment:1 Changed 9 years ago by snover

Component: unfiledeffects
Priority: highlow
Status: newopen
Summary: Bug in show in jQuery 1.4.3.rc1only set overflow in $.fn.animate when the default overflow is visible
Version: 1.4.21.4.3rc

IE8 functions the same as all other modern browsers: the overflow attribute of an element with an animated width or height is set to hidden until after the animation is complete in order to prevent content from overflowing during animations.

In IE6 and IE7, the overflow value remains hidden after the animation is complete because these browsers shrink wrap content in an element with layout. If you are running IE8 in IE7 mode, this is probably what you are experiencing.

We should probably only set overflow when the default overflow is not visible.

comment:2 Changed 9 years ago by snover

Milestone: 1.4.3

Resetting milestone to future.

comment:3 Changed 8 years ago by timmywil

Milestone: 1.next
Resolution: duplicate
Status: openclosed

comment:4 Changed 8 years ago by timmywil

Duplicate of #3986.

Note: See TracTickets for help on using tickets.