Bug Tracker

Opened 11 years ago

Closed 9 years ago

Last modified 9 years ago

#3986 closed bug (fixed)

slideUp/slideDown clobbers inline overflow-x/y

Reported by: tonyt Owned by: flesler
Priority: low Milestone: 1.next
Component: effects Version: 1.3.2
Keywords: Cc:
Blocked by: Blocking:

Description

To demostrate the problem here is the example code:

<div id="mydiv" style="overflow-x:auto;overflow-y:hidden;width: 50px;height:50px;"> Put some data here so that we have horizontal scrollbar </div>

When we apply slideUp and then slideDown to the div element the overflow-x and overflow-y are removed and we lost the styling.

Attachments (1)

test-3986.html (893 bytes) - added by dmethvin 11 years ago.
Example of working overflow-x/y using stylesheet

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by dmethvin

Owner: set to flesler
Summary: slideUp/slideDown problemslideUp/slideDown clobbers inline overflow-x/y

Most likely because fx changes the overflow property as a whole, but you have overflow-x and overflow-y set as an inline style on the element. If you set those two css properties using a style sheet, it works as intended.

The jQuery animation could try setting the two overflow properties separately, but they're not supported on all platforms are they?

Changed 11 years ago by dmethvin

Attachment: test-3986.html added

Example of working overflow-x/y using stylesheet

comment:2 in reply to:  1 Changed 11 years ago by tonyt

Replying to dmethvin:

Most likely because fx changes the overflow property as a whole, but you have overflow-x and overflow-y set as an inline style on the element. If you set those two css properties using a style sheet, it works as intended.

The jQuery animation could try setting the two overflow properties separately, but they're not supported on all platforms are they?

Hello, Thank you for the answer. Yes it works this way, but here is anothe issue. Using my example with inline setted overflow-x overflow-y when apply hide and the show - all is ok, but when we set hide and then show(param) where param is one of - slow, normal, fast - the div brakes again. Why in first case it works, but in othere does not?

P.S It seems that overflow-x overflow-y are supported of all browsers that jQuery support (except maybe Opera 9.25) Here is the link http://code.google.com/p/doctype/wiki/OverflowXCSSProperty http://code.google.com/p/doctype/wiki/OverflowYCSSProperty

Thank you Best Regards Tony

comment:3 Changed 10 years ago by dmethvin

Component: unfilledfx
Milestone: 1.3.2
Version: 1.3.11.3.2

comment:4 Changed 9 years ago by dmethvin

Priority: majorlow
Status: newopen

comment:5 Changed 9 years ago by timmywil

Milestone: 1.next
Resolution: fixed
Status: openclosed

comment:6 Changed 9 years ago by timmywil

#7160 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.