Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#7149 closed bug (duplicate)

Problem with jquery-ui dialog

Reported by: rodryquintero Owned by:
Priority: undecided Milestone: 1.4.3
Component: unfiled Version: 1.4.2
Keywords: jqueryui dialog Cc:
Blocked by: Blocking:

Description

I have the following code for a jquery dialog:

$("#dia-login-error").dialog(

{

autoOpen: false, modal: true, resizable: false, buttons: { "OK": function() { $(this).dialog("close"); }}

});

and this gives me the following error using 1.4.3RC:

h is null

[Break on this error] b){var d=[],e,g,h=this[0];if(c.isArray...h=h.parentNode;if(!h.ownerDocument

When I comment out the dialog declaration the error disssapears.

Change History (3)

comment:1 Changed 9 years ago by addyosmani

need: ReviewPatch

Recreated the above test case here: http://jsfiddle.net/addyosmani/myTAy/2/

Using jQuery 1.4.2 the UI components are working fine but switching over to the 1.4.3 RC is causing some breakage. I'm not seeing the exact same errors as originally submitted (instead d.ui.plugin is undefined / dialog is not a function).

Confirming this is an issue across FF, Opera and Webkit browsers. Have yet to test with IE.

comment:2 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

addysomani your testcase is broken. The problem is with the buttons property. This is a duplicate of #7147.

comment:3 Changed 9 years ago by addyosmani

snover: The test case was broken on purpose to show breakage - was there something else in there you noticed that needs correcting? If so, let me know and I'll update.

Note: See TracTickets for help on using tickets.