Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7147 closed bug (duplicate)

1.4.3 RC1 breaks jQuery UI dialog

Reported by: jagid Owned by: john
Priority: blocker Milestone: 1.4.3
Component: traversing Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

I know that there is a jQuery UI element to this issue but as the below code works with 1.4.2 a change in 1.4.3 is causing the issue. With the below code the dialog does not display unless the buttons line is removed.

<div id="testdiv">Test content<div>

<link href="http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.4/themes/smoothness/jquery-ui.css" rel="stylesheet" type="text/css" /> <script type="text/javascript" src="http://code.jquery.com/jquery-1.4.3rc1.js"></script> <script type="text/javascript" src="http://ajax.googleapis.com/ajax/libs/jqueryui/1.8.4/jquery-ui.min.js"></script> <script type="text/javascript">

$(document).ready(function () {

$("#testdiv").dialog({

buttons: { "OK": function () { alert($(this).html()); }}

});

});

</script>

Change History (3)

comment:1 Changed 9 years ago by snover

Owner: set to snover
Priority: undecidedblocker
Status: newassigned

Issue only occurs with buttons property active. Looks like jQuery 1.4.3 checks for properties on cur in .closest but cur is not always defined, so it generates an error. Line 4193 needs a !cur in the conditional. Live test case

comment:2 Changed 9 years ago by snover

Component: unfiledtraversing
need: ReviewCommit
Owner: changed from snover to john
Status: assignednew

comment:3 Changed 9 years ago by john

Resolution: duplicate
Status: newclosed

Duplicate of #7142.

Note: See TracTickets for help on using tickets.