Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#7148 closed bug (fixed)

1.4.3rc1: Cannot get styles from disconnected nodes

Reported by: scottgonzalez Owned by: john
Priority: low Milestone: 1.4.3
Component: css Version: 1.4.2
Keywords: css disconnected nodes Cc:
Blocked by: Blocking:

Description

.css() now returns an empty string when trying to get style properties from elements that are not part of the page.

$( "<div>" ).css( "left", "20%" ).css( "left" )

demo: http://jsbin.com/iluhi4/edit

Change History (5)

comment:1 Changed 9 years ago by addyosmani

Keywords: css disconnected nodes added

Scott, did you notice this happening in all major browsers or just one in particular? If the latter, could you elaborate on which one?.

Currently testing this on FF 3.6.10/OSX and it seems to be working fine.

comment:2 Changed 9 years ago by miketaylr

Not working in Opera 10.62/Mac.

comment:3 Changed 9 years ago by addyosmani

need: ReviewPatch
Owner: set to john
Priority: undecidedlow

Issue confirmed as not working in:

Opera 10.62 Chrome 6.04 Safari 5.02

Currently appears to be working fine in FireFox 3.6.10/OSX.

Flagging for review/patch if possible.

comment:4 Changed 9 years ago by john

Resolution: fixed
Status: newclosed

comment:5 in reply to:  4 Changed 8 years ago by caii

Replying to john:

Landed http://github.com/jquery/jquery/pull/47

in IE<9 STILL BUG

Note: See TracTickets for help on using tickets.