Bug Tracker

Opened 9 years ago

Closed 9 years ago

#7126 closed bug (duplicate)

.parents('[attribute*=value]') doesn't work with style attribute

Reported by: pejovica Owned by:
Priority: undecided Milestone: 1.4.3
Component: traversing Version: 1.4.2
Keywords: Cc:
Blocked by: Blocking:

Description

I was trying to match a div with .parents('[style*=opacity]') but I was getting back an empty array, although the div was definitely there.

Firebug showed that jQuery is comparing "opacity" with "[object CSSStyleDeclaration]" instead of the text content of style attribute.

Change History (1)

comment:1 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

Duplicate of #3399.

Note: See TracTickets for help on using tickets.