Bug Tracker

Opened 11 years ago

Closed 9 years ago

Last modified 8 years ago

#3399 closed bug (duplicate)

attribute selector does not match style attribute

Reported by: aaroncrane Owned by: anonymous
Priority: low Milestone: 1.4.3
Component: selector Version: 1.4.2
Keywords: Cc: jquery@…, flesler
Blocked by: Blocking:

Description

Attribute selectors of the form 'div[style]' and 'div[title]' do not work as I expect.

I expect 'div[style]' to match every <div> element that bears a style= attribute (regardless of whether that attribute's value is the empty string), and not to match any <div> elements that do not bear any style= attribute.

However, that selector matches every <div>, regardless of whether it has a style= attribute.

I have similar expectations for 'div[title]', except with the title= attribute rather than style=. That selector correctly excludes <div> elements with no title= attribute, but it incorrectly matches <div title=""> elements (with an empty string as the attribute value).

Reductions for both situations are attached. I expect each reduction to display three green-background boxes saying "OK"; a failure is indicated as a red-background box saying "FAIL".

I have tested this in Firefox 2, Firefox 3, Safari 3.0, and Opera 9.5; it behaves the same way in all of them.

Attachments (3)

style.html (1.0 KB) - added by aaroncrane 11 years ago.
Reduction for 'div[style]' selectors
title.html (1.0 KB) - added by aaroncrane 11 years ago.
Reduction for 'div[title]' selectors
style-attribute-selector.htm (1.2 KB) - added by matejr 11 years ago.
Style attribute selector not working

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by aaroncrane

Attachment: style.html added

Reduction for 'div[style]' selectors

Changed 11 years ago by aaroncrane

Attachment: title.html added

Reduction for 'div[title]' selectors

comment:1 Changed 11 years ago by flesler

Cc: flesler added
Component: unfilledselector
Milestone: 1.3
Status: newassigned

Changed 11 years ago by matejr

Style attribute selector not working

comment:2 Changed 11 years ago by matejr

Style attribute selector doesn't work at all. If I use attribute selector [attribute*=value] the exception is throwed: z.indexOf is not a function

I attached one more file, which demonstrates this.

comment:3 Changed 9 years ago by snover

#4068, #6044, #7078, #7126 are duplicates of this bug.

comment:4 Changed 9 years ago by snover

Milestone: 1.31.4.3
Owner: changed from flesler to anonymous
Priority: majorlow
Status: assignednew
Summary: Inconsistent results with attribute selectors in jQuery 1.2.6attribute selector does not match style attribute
Version: 1.2.61.4.2

comment:5 Changed 9 years ago by snover

Resolution: duplicate
Status: newclosed

comment:6 Changed 9 years ago by snover

Duplicate of #7128.

Note: See TracTickets for help on using tickets.