Bug Tracker

Ticket #7103 (closed bug: duplicate)

Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#7103 closed bug (duplicate)

Non-standard CSS property values on IE

Reported by: aivopaas Owned by:
Priority: blocker Milestone: 1.4.3
Component: css Version: 1.4.2
Keywords: css background rgba ie Cc:
Blocked by: Blocking:


Setting rgba and probably other CSS3 property values results in unhandled exception on Internet Explorer.

Test case:

$('<div>RGBA</div>').appendTo('body').css('backgroundColor', 'rgba(0,0,0,0.8)');

Fails on 1.4.2 and latest nightly

Other browsers set background color to the correct value, while IE8 just runs into exception. While IE does not support alpha values on background, maybe colors could be converted to RGB hex values. Support for rgba should be easily feature-detected. Removing alpha value for non-suporting browsers would make it run and not crash. The result would be not as pretty as intended, but we should at least be able to benefit from modern browsers.

Change History

comment:1 Changed 5 years ago by snover

comment:1 Changed 5 years ago by snover

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5509.

Note: See TracTickets for help on using tickets.