Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#5509 closed bug (fixed)

Setting rgba value as border color makes jquery halt

Reported by: adamkiss Owned by: snover
Priority: critical Milestone: 1.4.3
Component: css Version: 1.4.2
Keywords: ie8, ie7, rgba, css Cc:
Blocked by: Blocking:

Description

If you try to use rgba value as 'border-right-color', IE8 reports error 'Incorrect value of properties' both in standard and IE7-compatible mode.

When trying to use google to find solution, it seems, that if you try to set value of css-property of element to value unknown to browser (IE in most cases), jquery fails.

Using minified version, code is around position: 12949 in following part: if(L){/*here*/J[G]=K}alert(J[G]);

Thank you in advance, sorry for my english

Change History (9)

comment:1 Changed 10 years ago by adamkiss

formatted problematic code:

if(L){/*here*/J[G]=K}alert(J[G]);

code calling this function/ setting this values:

$("#nav li:not(:last)").css('border-right','1px solid rgb(249,233,255)').css('borderRightColor','rgba(249,233,255,0.2)');

comment:2 Changed 10 years ago by adamkiss

better formatting of code used, both

$("#nav li:not(:last)")
.css('border-right','1px solid rgb(249,233,255)')
.css('border-right-color','rgba(249,233,255,0.2)');

and

$("#nav li:not(:last)")
.css('border-right','1px solid rgb(249,233,255)')
.css('borderRightColor','rgba(249,233,255,0.2)');

comment:3 Changed 9 years ago by dmethvin

Component: unfiledattributes

IE doesn't support the rgba format, since it also doesn't support opacity. It throws an error since it doesn't recognize the format.

What would be the correct thing to do here? It could be very expensive to try and filter any color value strings being set as css attributes. Pushing the decision back to the caller may be best.

comment:4 Changed 9 years ago by dmethvin

Component: attributescss

comment:5 Changed 9 years ago by snover

#7103 is a duplicate of this bug.

Maybe we should add an rgba support test which will allow authors to branch based on support, and just swallow any errors (since normally, invalid CSS is discarded).

comment:6 Changed 9 years ago by snover

Owner: set to snover
Status: newassigned

comment:7 Changed 9 years ago by snover

need: PatchCommit

comment:8 Changed 9 years ago by john

Milestone: 1.41.4.3
Resolution: fixed
Status: assignedclosed
Version: 1.3.21.4.2

comment:9 Changed 9 years ago by snover

#5790 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.