Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#7084 closed bug (duplicate)

conflict between Array object and cloning events

Reported by: emile.g Owned by:
Priority: undecided Milestone: 1.4.3
Component: unfiled Version: 1.4.2
Keywords: clone, event Cc:
Blocked by: Blocking:

Description

If the Array object has been added new methods, the clone(true) method will cause strange behaviour on the cloned element :

  • bind events to an element
  • clone the element with its events : $().clone(true)
  • trigger any event of the new cloned element

=> Array added methods are executed

Exemple on jsbin : http://jsbin.com/urite/2

Change History (1)

comment:1 Changed 9 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #6355.

Note: See TracTickets for help on using tickets.