Bug Tracker

Opened 8 years ago

Closed 8 years ago

#7068 closed bug (duplicate)

Animation breaks with incorrect easing function name

Reported by: Motty Owned by:
Priority: undecided Milestone: 1.4.3
Component: effects Version: 1.4.2
Keywords: easing Cc:
Blocked by: Blocking:

Description

Adding an incorrect easing function name will cause an error

    $("#block").animate({
        width: "100px"
    }, 1500, "schwing");  // incorrect easing name causes error

Demo here: http://jsfiddle.net/5Rm5T/

I believe this might fix it, but maybe someone who knows the core better can find a better solution:

Line 5853:

var defaultEasing = jQuery.isFunction($.easing[this.options.easing]) ? this.options.easing : (jQuery.easing.swing ? "swing" : "linear");

Note: corrected repost of ticket #7064.

Change History (1)

comment:1 Changed 8 years ago by snover

Priority: undecided
Resolution: duplicate
Status: newclosed

Duplicate of #3626.

Note: See TracTickets for help on using tickets.