Bug Tracker

Opened 11 years ago

Closed 10 years ago

Last modified 9 years ago

#3626 closed bug (invalid)

Jquery assumes that options.easing is either valid or evaluates to false. This is incorrect.

Reported by: _Nate_ Owned by: flesler
Priority: minor Milestone: 1.3
Component: unfiled Version: 1.2.6
Keywords: Easing Cc:
Blocked by: Blocking:

Description

At the line:

this.pos = jQuery.easing[this.options.easing
(jQuery.easing.swing ? "swing" : "linear")](this.state, n, 0, 1, this.options.duration);

options.easing is sometimes not undefined, 'linear', or 'swing', which results in a key error.

A fix is to put the lines

if(this.options.easing != 'swing' && this.options.easing != 'linear') this.options.easing = undefined

or something to that effect above the line mentioned above. However, there may be an underlying issue as to why this.options.easing is not undefined when not set

Change History (2)

comment:1 Changed 10 years ago by dmethvin

Resolution: invalid
Status: newclosed

I'll close this ticket since it's been open for so long and not reported by anyone else. The code seems to be unchanged in 1.3.2; reopen the ticket if you can provide a test case that reproduces the issue.

comment:2 Changed 9 years ago by snover

Ticket #7068 is a duplicate of this issue.

Note: See TracTickets for help on using tickets.