Bug Tracker

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6997 closed bug (fixed)

before and after do not clone events data properly

Reported by: israelrios Owned by: john
Priority: blocker Milestone: 1.5
Component: manipulation Version: 1.4.2
Keywords: before clone Cc:
Blocked by: Blocking:

Description

The documentation says insertBefore() and before() behavior is similar but with params and object inverted. But, when clones are made of the inserted element this isn't true. The insertBefore() clone the element's events and data, but before() does not.

Change History (12)

comment:1 Changed 5 years ago by snover

  • Milestone 1.4.2 deleted
  • Owner set to israelrios
  • Priority set to undecided
  • Status changed from new to pending

Please provide a test case demonstrating this issue.

comment:2 Changed 5 years ago by israelrios

  • Status changed from pending to new

I created a test case:

http://jsfiddle.net/AcepV/4/

comment:3 Changed 5 years ago by snover

  • Milestone set to 1.next
  • Priority changed from undecided to blocker
  • Status changed from new to open

comment:4 Changed 5 years ago by snover

  • Summary changed from insertBefore() and before() clone behavior differ to before and after do not clone events data properly

comment:5 Changed 5 years ago by snover

  • Milestone changed from 1.4.4 to 1.4.5

Retargeting due to severity of 1.4.3 regressions.

comment:6 Changed 5 years ago by snover

  • Milestone changed from 1.4.5 to 1.4.4

Retargeting for 1.4.4 as per John’s request.

comment:7 Changed 5 years ago by john

  • Owner changed from israelrios to john
  • Status changed from open to assigned

comment:8 Changed 5 years ago by snover

  • Milestone changed from 1.4.4 to 1.4.5

Retargeting to next minor release.

comment:9 Changed 5 years ago by snover

  • Resolution set to duplicate
  • Status changed from assigned to closed

comment:10 Changed 5 years ago by snover

Duplicate of #5566.

comment:11 Changed 5 years ago by Colin Snover

  • Resolution changed from duplicate to fixed

Merge branch 'bug5566' into csnover-bug5566. Fixes #4386, #5566, #6997.

Conflicts:

src/manipulation.js test/unit/manipulation.js

Changeset: 4fae75d575b20d887e4a273c7991c55f8821a62c

comment:7 Changed 5 years ago by jitter

  • Milestone changed from 1.4.5 to 1.5

Move fixed tickets to appropriate milestone

Note: See TracTickets for help on using tickets.