Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#6877 closed bug (duplicate)

Change event not firing on select box on keypress

Reported by: meyerovb Owned by:
Priority: undecided Milestone: 1.4.3
Component: event Version: 1.4.2
Keywords: Cc: bryanam@…
Blocked by: Blocking:

Description

Test the attached code on ie8 by pressing the down key on the keyboard once the page loads. No alert box appears until you blur the select box. Change the jquery version to 1.2.3 instead of 1.4.2, and you get an alert as soon as you press the down key.

Attachments (1)

select_change.html (444 bytes) - added by meyerovb 9 years ago.
Test case

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by meyerovb

Attachment: select_change.html added

Test case

comment:1 Changed 9 years ago by addyosmani

need: ReviewPatch
Priority: undecided

I've examined your code and tested it across both IE8 and several other browsers (Safari, Chrome, FF) to verify the behaviour experienced.

Although you are able to trigger the alert in IE by manually changing the selected item, as you rightly say - attempting to do this from the keyboard does not execute the alert as it should.

An alternative workaround could be created by modifying your original solution using .keydown() or .keyup() to detect the keystrokes applied to the select.

Flagging for review and possible patch.

comment:2 Changed 9 years ago by john

Resolution: duplicate
Status: newclosed

Duplicate of #6374.

Note: See TracTickets for help on using tickets.