Bug Tracker

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#6489 closed bug (duplicate)

e.which not working correctly in Internet Explorer

Reported by: kayahr Owned by:
Priority: undecided Milestone: 1.4.2
Component: event Version: 1.4.2
Keywords: IE Cc:
Blocked by: Blocking:

Description

In mouse events jQuery does not translate the mouse button index correctly into the e.which property in Internet Explorer. It works when only one button is pressed at once but it fails when you press multiple buttons.

You can watch the bug in this demo: http://www.ailis.de/~k/permdata/20100427/whichbug/

Press down the left mouse button (Somewhere in the page), then press the right mouse button, then release the mouse left mouse button and then release the right mouse button. Do this in Firefox and you will see that the log output is correct. Do it in IE and you see that the mousedown of the right mouse button is reported as a mousedown of the left mouse button. But the mouseup events are correct in this example. The same can be reproduces with the middle mouse button.

Change History (2)

comment:1 Changed 9 years ago by dmethvin

Priority: undecided
Resolution: duplicate
Status: newclosed

comment:2 Changed 9 years ago by dmethvin

Duplicate of #2338.

Note: See TracTickets for help on using tickets.