Bug Tracker

Opened 12 years ago

Closed 9 years ago

Last modified 9 years ago

#2338 closed bug (fixed)

jQuery.event.fix() mangles "event.which" when it == false

Reported by: DarkRyder Owned by:
Priority: minor Milestone: 1.4.3
Component: event Version: 1.4.2
Keywords: opera keypress Cc:
Blocked by: Blocking:

Description

The current implementation of jQuery.event.fix() uses !event.which to determine whether to alter its value, which causes it to get mangled if its value is 0:

// Add which for key events
if ( !event.which && ((event.charCode || event.charCode === 0) ? event.charCode : event.keyCode) )
	event.which = event.charCode || event.keyCode;

This would be a non-issue except that checking whether event.which === 0 is the only way to distinguish between certain keys in Opera (notoriously, the single-quote key and the right arrow key). Below is an implementation which corrects this problem by explicitly testing whether event.which et al. have been defined.

// Add which for key events
if ( typeof event.which == "undefined" && (typeof event.charCode != "undefined" || typeof event.keyCode != "undefined") )
	event.which = typeof event.charCode != "undefined" ? event.charCode : event.keyCode;

Attached are a simple test case and a diff of event.js against revision 4750.

Attachments (2)

jquery-which.html (1.3 KB) - added by DarkRyder 12 years ago.
jquery-4750-which.diff (691 bytes) - added by DarkRyder 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by DarkRyder

Attachment: jquery-which.html added

Changed 12 years ago by DarkRyder

Attachment: jquery-4750-which.diff added

comment:2 Changed 9 years ago by john

Milestone: 1.2.41.4.3
Resolution: fixed
Status: newclosed
Version: 1.2.31.4.2

comment:3 Changed 9 years ago by dmethvin

#6489 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.