Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#6233 closed bug (duplicate)

Selector [name="person.names[0]"]:visible fails

Reported by: mjezierski Owned by:
Priority: low Milestone: 1.next
Component: selector Version: 1.4.4
Keywords: Cc:
Blocked by: Blocking:

Description

Selector [name="person.names[0]"]:visible fails due to wrong selector split. Proposed patch: CLASS: /\.((?:[\w\u00c0-\uFFFF-]|
.)+)/, change to CLASS: /[[]*\.((?:[\w\u00c0-\uFFFF_-]|
.)+)/,

Attachments (1)

testcase.html (1.4 KB) - added by mjezierski 10 years ago.
Test case

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by mjezierski

Attachment: testcase.html added

Test case

comment:1 Changed 10 years ago by john

Component: unfiledselector

comment:2 Changed 9 years ago by snover

Milestone: 1.4.3
Priority: low
Status: newopen
Version: 1.4.21.4.4

comment:3 Changed 9 years ago by Chealer9

Also broken: [id="
"]:visible I don't know if the reason is the same.

comment:4 Changed 9 years ago by danheberden

Milestone: 1.next

A bit more in-depth of a test-case: http://jsfiddle.net/danheberden/XmymL/1/

comment:5 Changed 9 years ago by danheberden

Resolution: duplicate
Status: openclosed

comment:6 Changed 9 years ago by danheberden

Duplicate of #5020.

Note: See TracTickets for help on using tickets.