Bug Tracker

Opened 10 years ago

Closed 8 years ago

Last modified 8 years ago

#5020 closed bug (duplicate)

Attribute selector with filter fails

Reported by: maciekj Owned by: john
Priority: major Milestone: 1.next
Component: selector Version: 1.4.3
Keywords: attribute selector filter Cc:
Blocked by: Blocking:

Description

Attribute selector combined with filter fails in 1.3.2 when attribute value contains dot. However it works in 1.2.6.

Code to run on example (attached) html: $("[name='group.phones[0].number']:visible")

expected: 1 element got 0 elements

Attachments (1)

test.html (420 bytes) - added by maciekj 10 years ago.
example html

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by maciekj

Attachment: test.html added

example html

comment:1 Changed 10 years ago by maciekj

Adding ^[^]] at the start of CLASS regexp seems to solve the problem.

   original: CLASS: /\.((?:[\w\u00c0-\uFFFF_-]|\\.)+)/
   fixed:    CLASS: /^[^[]*\.((?:[\w\u00c0-\uFFFF_-]|\\.)+)/

comment:2 Changed 9 years ago by addyosmani

Keywords: needsreview attribute selector filter added
Milestone: 1.4
Status: newopen
Version: 1.3.21.4.3

Reproduced here: Live Test Case. It would appear that this broke in jQuery 1.3.2 and has been broken since then.

comment:3 Changed 9 years ago by dmethvin

Keywords: needsreview removed

comment:4 Changed 9 years ago by danheberden

#6233 is a duplicate of this ticket.

comment:5 Changed 9 years ago by danheberden

Milestone: 1.next

comment:6 Changed 8 years ago by john

Resolution: duplicate
Status: openclosed

comment:7 Changed 8 years ago by john

Duplicate of #4740.

Note: See TracTickets for help on using tickets.