Bug Tracker

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#6006 closed feature (duplicate)

Add `object of event/handler pairs` as an option argument to $.fn.delegate

Reported by: deadlyicon Owned by: brandon
Priority: minor Milestone: 1.4.2
Component: event Version: 1.4.1
Keywords: Cc:
Blocked by: Blocking:

Description

Extending the API to allow the following:

$(document).delegate(selector, {event:handler});

Attachments (1)

0001-added-object-as-event-fn-pairs-support-to-delegate.patch (5.0 KB) - added by deadlyicon 10 years ago.
patch on top of f9417b9da980f4fa79d03ba691d9f3442c5ab2f2

Download all attachments as: .zip

Change History (5)

comment:1 Changed 10 years ago by john

Shouldn't we probably add this to .live() first? It's likely that the changes to delegate would become either simpler or go away altogether.

comment:2 Changed 10 years ago by deadlyicon

agreed. I'll put together a patch for that

comment:4 Changed 9 years ago by dmethvin

Resolution: duplicate
Status: newclosed

comment:5 Changed 9 years ago by dmethvin

Duplicate of #6282.

Note: See TracTickets for help on using tickets.